Instalation problems

Feb 14, 2013 at 1:58 PM
I have a SQL SERVER 2012 (64 bit) with VS 2010 installed (default)
I run the setup and it copied the files under C:\Program Files (x86)\SSIS Extensions

When I run VS the task don't show up .....

How to fix this?
Feb 14, 2013 at 2:29 PM
reinstalled it in: C:\Program Files\Microsoft SQL Server\110\DTS\Tasks

didn't show up
Feb 14, 2013 at 10:24 PM
yes there was an issue with the installer i've updated the downloads section with 64 bit SQL 2012 installer, so please download and retry. Thanx
Feb 14, 2013 at 10:31 PM
make sure you remove any previous installation using Add/Remove programs.
Feb 15, 2013 at 12:29 AM
Sorry I see only a update for 2008r2 but I'm on 2012

SQL 2012
Feb 3, 2013, Stable
Feb 15, 2013 at 12:31 AM
I installed a package RegExFlatFileSourceSetup_SQL2012.msi worked fine .. double cheked the gacutil is installed correct
Apr 8, 2013 at 11:11 PM
I can't seem to choose another installation directory and the tools are not showing up in the toolbox. SQL 2012 64bit, VS 2010 and 2012 with SSDT installed for both. Thoughts?
Apr 21, 2013 at 4:20 PM
Does the installation finish successfully? The components will be installed in the directory specified by the Registry Key "HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\110\DTS\Setup", usually in "C:\Program Files\Microsoft SQL Server\110\DTS\Tasks".
  • Verify that SSIS.Extensions.dll and SSIS.Extensions.UI.dll exist in that directory.
  • Verify that both dlls also exist in GAC. (usually in "C:\Windows\Microsoft.NET\assembly\gac..")
Apr 22, 2013 at 4:07 PM
Thanks for the response mc. The dlls are installed in my installation directory represented in the DTS\Setup Reg Key (mine is D drive fyi). The also do exist in the gac in the following location: C:\Windows\Microsoft.NET\assembly\GAC_MSIL.

Are these compiled using .net 4.0?

Thank you.
Apr 23, 2013 at 12:39 AM
Yes SQL 2012 files, are compiles using .net 4.0. I will try to find a machine with SQL 2012 64 bit so i can test this. Will update of my findings. thanx.
Apr 26, 2013 at 8:17 PM
For what it is worth the assemblies appear under the 4.0 gac:


My reg key points here (and I see the dlls here as well):

D:\Program Files\Microsoft SQL Server\110\DTS\Tasks

Server is 2008 R2 Enterprise.

Visual Studio 2012 version == Premium

Still can't get it to work...
May 19, 2013 at 6:14 PM
Fixed in the new installer. The DLL were being copied to the wrong folder. Since Visual studio is 32 bit the files needed to be copied to c:\program files (x86) folders.