Deploying Task failed to load

May 21, 2013 at 11:37 AM
I'm trying this tools which seems to be great.
In development, all is OK but when I deploy my package on my server, I can't execute the package. Error on validation : The task has failed to load. The contact information for this task is ""
May I have help please ?
This is Sql Server 2012 on Windows Server 2008 R2
Thanks a lot
May 21, 2013 at 1:33 PM
This works fine on another 32Bits server but not on my 64Bits Server
May 23, 2013 at 2:01 PM
Did you run installation on the production server? Ensure that the following DLLs exist in the GAC and in C:\Program Files (x86)\Microsoft SQL Server\110\DTS\Tasks
  • SSIS.Extensions.2012
  • SSIS.Extensions.UI.2012
I tried the zip task on my Win Server 2008R2 64-Bit machine with SQL2012 64-bit and it works fine.
May 23, 2013 at 4:15 PM
Yes I run installation on the production server.
Theses dll are in C:\Program Files (x86)\Microsoft SQL Server\110\DTS\Tasks and in the GAC.
It works fine in my Visual Studio Solution but not when deployed in SSIS Store
May 27, 2013 at 2:03 PM
I developed my package on 32bits and I tried to deploy on 64bits. If I open my 32 bits package with Visual Studio on 64 bits, build and deploy, it works. Thanks for your help.