PGP losing file extension

Jan 15, 2015 at 6:15 PM
This may be a stupid question, but I'm using the PGP component to encrypt a file. Say test.txt. The output is the test.pgp. When I decrypt the file, I need the file to again be named test.txt. Currently it comes out without the file extension (just test). I've tried making the input file test.txt.txt in hopes it was just removing the last extension, but the decrypted file still ended up as just plain "test". Is there anything I can do to address this?

I know it is a stupid trivial problem, but I need to feed the encrypted file to a client who requires the file to be encrypted, but when decrypted end in .txt and apparently them appending a .txt to each file after decryption isn't a good option for them.
Jan 15, 2015 at 6:45 PM
Edited Jan 15, 2015 at 6:54 PM
Are you sure that the filename does not include the file extension?
Is it possible that Windows Explorer is set to NOT display the extensions of known file types?
If you double-click on the file will it open in the default text editor?

Good luck.
Jan 15, 2015 at 7:28 PM
Unfortunately not. Here is what I see from a before, encrypted, after state.
Jan 15, 2015 at 7:35 PM
Edited Jan 15, 2015 at 8:00 PM
Also, the config is this: (I've tried armored and not)

User::TransFile = @[User::Trans] + ".txt"
User::TransFilePGP = @[User::Trans] + ".pgp"

Both versions of the file are properly named via the above config after the job runs. However, after a decrypt (both in my testing locally and also my clients testing on their side) the resulting file is missing the file extension. Using SQL 2008 R2.... Not sure what else I can add.

As mentioned just on a lark, I also tried:
User::TransFile = @[User::Trans] + ".txt.txt"

But the results were the same (except the input file before encryption was named *.txt.txt).